Fix support for older libwebsocket versions

Multimedia / Ardour - Robin Gareus [gareus.org] - 10 June 2020 13:58 UTC

LWS_WITH_EXTERNAL_POLL a new optional define for libwebsocket 4.x. Earlier versions always supported it, without the compile-time define.

This fixes support for libwesocket 2.x (Debian, Ubuntu), and 3.x. Also for Windows, LWS_WITH_GLIB is not available.

5296ed141f Fix support for older libwebsocket versions
libs/surfaces/websockets/server.cc | 18 +++++++++++-------
1 file changed, 11 insertions(+), 7 deletions(-)

  • Share