Backend: Remove old llvm support code

Graphics / Beignet - Pan Xiuli [intel.com] - 13 April 2017 07:39 EDT

LLVM 3.3 or older is not supportted by Beignet now, and we need delete these codes.

c6497b1 Backend: Remove old llvm support code.
backend/src/backend/gen_program.cpp | 6 ------
backend/src/backend/program.cpp | 30 ------------------------------
backend/src/llvm/llvm_gen_backend.cpp | 22 ----------------------
backend/src/llvm/llvm_printf_parser.cpp | 6 ------
backend/src/llvm/llvm_profiling.cpp | 20 --------------------
backend/src/llvm/llvm_scalarize.cpp | 6 ------
6 files changed, 90 deletions(-)

Upstream: cgit.freedesktop.org


  • Share