Update generate_gradle.py to support Java 8.

Desktop / Chromium - Sami Kalliomäki [chromium.org] - 10 August 2017 12:27 EDT

Adds support for Java 8 using Desugar. Android Studio 3.0 is required for Desugar. enforceUniquePackageName is no longer needed by the new gradle version. This feature is behind "--canary" flag for now.

Bug: webrtc:8084, chromium:730711 Change-Id: Iba24880fef303aa627307356f2e26b78e153a960 Reviewed-on: https://chromium-review.googlesource.com/609066

8f75411 Update generate_gradle.py to support Java 8.
build/android/gradle/android.jinja | 7 +++++++
build/android/gradle/dependencies.jinja | 4 ++++
build/android/gradle/generate_gradle.py | 21 +++++++++++++++------
build/android/gradle/java.jinja | 5 +++++
build/android/gradle/root.jinja | 9 +++++++++
5 files changed, 40 insertions(+), 6 deletions(-)

Upstream: git.chromium.org


  • Share