check: Bump version to 0.9.10 and change macro

Desktop / Enlightenment / EFL Core Libraries - Jean-Philippe Andre [samsung.com] - 29 May 2017 22:02 EDT

Changing ck_assert_ptr_nonnull() to ck_assert_ptr_ne() in order to require "only" check >= 0.9.10. ck_assert_ptr_nonnull() was introduced in 0.11.0. ck_assert_ptr_ne() is already used a lot in the test suite so a recent version of check is required.

###

diff --git a/configure.ac b/configure.ac
index 12d7f26..a324018 100644
--- a/configure.ac
+++ b/configure.ac
@@ -380,7 +380,7 @@ AM_CONDITIONAL([EFL_ENABLE_COVERAGE], [test "${want_coverage}" = "yes"])
# check unit testing library

if test "${want_tests}" = "yes"; then
- PKG_CHECK_MODULES([CHECK], [check >= 0.9.5])
+ PKG_CHECK_MODULES([CHECK], [check >= 0.9.10])
fi
AM_CONDITIONAL([EFL_ENABLE_TESTS], [test "${want_tests}" = "yes"])

diff --git a/src/tests/edje/edje_test_edje.c b/src/tests/edje/edje_test_edje.c
index d92c8c0..9d31544 100644
--- a/src/tests/edje/edje_test_edje.c
+++ b/src/tests/edje/edje_test_edje.c
@@ -734,7 +734,7 @@ _message_signal_reply_cb(void *data, Evas_Object *obj EINA_UNUSED,
fprintf(stderr, "source %s emit %s id %d\n", source, emission, *id);
fflush(stderr);
ck_assert_str_eq(source, "edc");
- ck_assert_ptr_nonnull(emission);
+ ck_assert_ptr_ne(emission, NULL);

if (!strncmp(emission, "int set", 7))
ck_assert_str_eq(emission, "int set 7 12 42 255");

bc38a4c check: Bump version to 0.9.10 and change macro
configure.ac | 2 +-
src/tests/edje/edje_test_edje.c | 2 +-
2 files changed, 2 insertions(+), 2 deletions(-)

Upstream: git.enlightenment.org


  • Share