edje: add efl_version property

Desktop / Enlightenment / EFL Core Libraries - Youngbok Shin [samsung.com] - 14 June 2017 17:24 EDT

Summary: efl_version will be used to figure out which version of EFL lib is used to develop a edje file. If there is no property of efl_version, it will be 1.19 as default. This feature is needed to fix T5548.

Example: efl_version: 1 20

@feature

Test Plan: N/A

Reviewers: cedric, jpeg, herdsman, zmike, raster

Reviewed By: cedric

Maniphest Tasks: T5548

Differential Revision: https://phab.enlightenment.org/D4961

638ee88 edje: add efl_version property
src/bin/edje/edje_cc.c | 9 +++++++++
src/bin/edje/edje_cc_handlers.c | 25 +++++++++++++++++++++++++
src/lib/edje/edje_cache.c | 7 +++++++
src/lib/edje/edje_convert.c | 2 ++
src/lib/edje/edje_data.c | 2 ++
src/lib/edje/edje_private.h | 5 +++++
6 files changed, 50 insertions(+)

Upstream: git.enlightenment.org


  • Share