Add a compatibility layer to protect against ecore_drm2 api change

Desktop / Enlightenment / Enlightenment - Derek Foreman [osg.samsung.com] - 9 August 2017 15:59 EDT

In case we roll an E release before the next EFL one, we need these API changes to be hidden.

Later we can remove this...

0fd2392 Add a compatibility layer to protect against ecore_drm2 api change
src/bin/Makefile.mk | 2 +-
src/bin/e_alert_main.c | 14 +++--
src/bin/e_drm2.x | 117 ++++++++++++++++++++++++++++++++++++++++
src/modules/wl_drm/e_mod_main.c | 20 ++++---
4 files changed, 139 insertions(+), 14 deletions(-)

Upstream: git.enlightenment.org


  • Share