qsv: add requirement for the mininal version of libmfx

Multimedia / FFmpeg - Haihao Xiang [ffmpeg.org] - 25 May 2022 07:17 UTC

libmfx 1.28 was released 3 years ago, it is easy to get a greater
version than 1.28. We may remove lots of compile-time checks if adding the requirement for the minimal version in the configure script.

478e1a98a2 qsv: add requirement for the mininal version of libmfx
configure | 7 +-
libavcodec/qsv.c | 24 ---
libavcodec/qsvenc.c | 476 ++++++++++++++++-----------------------------
libavcodec/qsvenc.h | 51 +----
libavcodec/qsvenc_h264.c | 6 -
libavcodec/qsvenc_hevc.c | 10 -
libavfilter/vf_scale_qsv.c | 13 +-
libavfilter/vf_vpp_qsv.c | 143 +++++++-------
libavutil/hwcontext_qsv.c | 2 -
9 files changed, 250 insertions(+), 482 deletions(-)

  • Share