Bump minimum MPFR version to 3.1.0

Programming / Compilers / GCC - jb [138bc75d-0d04-0410-961f-82ee72b054a4] - 11 November 2019 15:59 EST

Bump the minimum MPFR version to 3.1.0, released 2011-10-03. With this requirement one can still build GCC with the operating system provided MPFR on old but still supported operating systems like SLES 12 (MPFR 3.1.2) or RHEL/CentOS 7.x (MPFR 3.1.1).

This allows removing some code in the Fortran frontend, as well as fixing PR 91828.

ChangeLog:

2019-11-11 Janne Blomqvist

PR fortran/91828
- configure.ac: Bump minimum MPFR to 3.1.0, recommended to 3.1.6+.
- configure: Regenerated.

gcc/ChangeLog:

2019-11-11 Janne Blomqvist

PR fortran/91828
- doc/install.texi: Document that the minimum MPFR version is 3.1.0.

gcc/fortran/ChangeLog:

2019-11-11 Janne Blomqvist

PR fortran/91828
- simplify.c (gfc_simplify_fraction): Remove fallback path for MPFR < 3.1.0.

0a369f83048 Bump minimum MPFR version to 3.1.0
ChangeLog | 6 ++++++
configure | 6 +++---
configure.ac | 6 +++---
gcc/ChangeLog | 6 ++++++
gcc/doc/install.texi | 2 +-
gcc/fortran/ChangeLog | 6 ++++++
gcc/fortran/simplify.c | 37 -------------------------------------
7 files changed, 25 insertions(+), 44 deletions(-)

Upstream: gcc.gnu.org


  • Share