doc: Correct `--enable-version-specific-runtime-libs' support information