[kwin] Do not depend on KDE4WORKSPACE_VERSION

Desktop / KDE / KDE Workspace - Martin Gräßlin [kde.org] - 18 March 2014 04:52 EDT

KWin needs to have its own version. Split preparation.

###

diff --git a/kwin/CMakeLists.txt b/kwin/CMakeLists.txt
index ac7d20e..0047d65 100644
--- a/kwin/CMakeLists.txt
+++ b/kwin/CMakeLists.txt
@@ -13,7 +13,10 @@ option(KWIN_PLASMA_ACTIVE "Enable building KWin for Plasma Active." OFF)

# Binary name of KWin
set(KWIN_NAME "kwin")
-set(KWIN_VERSION ${KDE4WORKSPACE_VERSION})
+set(KWIN_VERSION_MAJOR 4)
+set(KWIN_VERSION_MINOR 90)
+set(KWIN_VERSION_PATCH 1)
+set(KWIN_VERSION ${KWIN_VERSION_MAJOR}.${KWIN_VERSION_MINOR}.${KWIN_VERSION_PATCH} )

if(KWIN_PLASMA_ACTIVE)
set(KWIN_BUILD_DECORATIONS OFF)

0b3dc40 [kwin] Do not depend on KDE4WORKSPACE_VERSION
kwin/CMakeLists.txt | 5 ++++-
1 file changed, 4 insertions(+), 1 deletion(-)

Upstream: quickgit.kde.org


  • Share