build fails with libxmlsec version 1.2.27

Desktop / LibreOffice - Lionel Elie Mamane [mamane.lu] - 2 August 2019 09:44 EDT

Due to indirect inclusion of C++ headers in scope of an 'extern "C"'. Possibly it works with version 1.2.24 to 1.2.26.

Change-Id: I12bd43b51b1cf829bfe91d4ab1eb5470b86ec18e Reviewed-on: https://gerrit.libreoffice.org/75349

###

diff --git a/configure.ac b/configure.ac
index b3f5390428fe..96f776280732 100644
--- a/configure.ac
+++ b/configure.ac
@@ -8300,7 +8300,7 @@ libo_CHECK_SYSTEM_MODULE([expat], [EXPAT], [expat])
dnl ===================================================================
dnl Check for system xmlsec
dnl ===================================================================
-libo_CHECK_SYSTEM_MODULE([xmlsec], [XMLSEC], [xmlsec1-nss >= 1.2.24])
+libo_CHECK_SYSTEM_MODULE([xmlsec], [XMLSEC], [xmlsec1-nss >= 1.2.28])

AC_MSG_CHECKING([whether to enable Embedded OpenType support])
if test "$_os" != "WINNT" -a "$_os" != "Darwin" -a "$enable_eot" = "yes"; then

6d482d0ac212 build fails with libxmlsec version 1.2.27
configure.ac | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

Upstream: cgit.freedesktop.org


  • Share