Bump Java baseline to Java 8

Desktop / LibreOffice - Stephan Bergmann [redhat.com] - 26 July 2019 12:26 EDT

...as discussed at "Minutes of ESC call: 2019-07-25".

3d27b2fa9c5a03f78e5145377402f8a88e3da1be "tdf#124503: Support JRE installations with unknown java.vendor property" had added support for JREs with unknown
vendor strings without checking that those JREs have a matching version (Java 6 back then, Java 8 now). That check has still not be implemented, assuming that Java 8 is old enough in practice so that any such JRE encountered in the wild will at least be Java 8 anyway.

Change-Id: I0205a34955368067c698bcabd24de84205a382bd Reviewed-on: https://gerrit.libreoffice.org/76365

aafc10c9edb6 Bump Java baseline to Java 8
configure.ac | 20 ++++++++++----------
.../OpenOfficeorg/javavendors_freebsd.xml | 10 +++++-----
.../OpenOfficeorg/javavendors_linux.xml | 16 ++++++++--------
.../OpenOfficeorg/javavendors_macosx.xml | 10 +++++-----
.../distributions/OpenOfficeorg/javavendors_unx.xml | 6 +++---
.../distributions/OpenOfficeorg/javavendors_wnt.xml | 10 +++++-----
6 files changed, 36 insertions(+), 36 deletions(-)

Upstream: cgit.freedesktop.org


  • Share