Do use -O1 for Apple Clang older than 9.1.0

Desktop / LibreOffice - Tor Lillqvist [collabora.com] - 18 April 2018 05:41 EDT

Don't want to risk breaking something by using -O2 with an older Clang, even if I don't remember exactly what the issue was when introducing the -O1 in 7b660e1423554928350e1de2cd4cb7eb577a27ec.

Change-Id: I2adeb0e8eb85a9b5021fca3d9e1e703cb5604a81 Reviewed-on: https://gerrit.libreoffice.org/53068

55b9706bea5a Do use -O1 for Apple Clang older than 9.1.0
config_host.mk.in | 1 +
configure.ac | 1 +
solenv/gbuild/platform/macosx.mk | 4 ++++
3 files changed, 6 insertions(+)

Upstream: cgit.freedesktop.org


  • Share