external: update pdfium to 5058

Desktop / LibreOffice - Miklos Vajna [collabora.com] - 20 May 2022 11:57 UTC

Which started to use require __builtin_is_constant_evaluated(), which our baseline doesn't have, so patch that out for now.

Change-Id: Idd1923291a933209d18bb677d011c9353c8f8c4d Reviewed-on: https://gerrit.libreoffice.org/c/core/+/134648

6a599ff57fb8 external: update pdfium to 5058
download.lst | 4 +-
external/pdfium/Library_pdfium.mk | 7 +--
external/pdfium/build.patch.1 | 64 ++++++++++++++++++++++++++
external/pdfium/cg-instead-of-carbon.patch.1 | 2 +-
external/pdfium/inc/pch/precompiled_pdfium.hxx | 14 +++---
5 files changed, 74 insertions(+), 17 deletions(-)

Upstream: cgit.freedesktop.org


  • Share