iOS, bump versions

Desktop / LibreOffice - jan Iversen [libreoffice.org] - 1 April 2018 16:21 EDT

SDK needed is 11.3 Xcode needed is 9.3

###

diff --git a/README.md b/README.md
index 1bbf9b58a481..c59f68122473 100644
--- a/README.md
+++ b/README.md
@@ -42,8 +42,8 @@ run and compile LibreOffice, also used by the TDF builds:
* Runtime: RHEL 6 or CentOS 6
* Build: GCC 4.8.1 or Clang
* iOS (only for LibreOfficeKit):
- * Runtime: 11.2 (only support for newer i devices == 64 bit)
- * Build: Xcode 9.0 and iPhone SDK 11.2
+ * Runtime: 11.3 (only support for newer i devices == 64 bit)
+ * Build: Xcode 9.3 and iPhone SDK 11.3

At least Clang 3.4.2 is known to be too old to pass the configure.ac check "whether $CXX supports
C++17, C++14, or C++11" in its current form (due to the #pragma GCC diagnostic ignored "-Wpragmas"
diff --git a/configure.ac b/configure.ac
index 73bc7b16a14d..e2d5c8c5e320 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2925,7 +2925,7 @@ dnl ===================================================================

if test $_os = iOS; then
AC_MSG_CHECKING([what iOS SDK to use])
- current_sdk_ver=11.2
+ current_sdk_ver=11.3
if test "$enable_ios_simulator" = "yes"; then
platform=iPhoneSimulator
versionmin=-mios-simulator-version-min=$current_sdk_ver

e63a65174800 iOS, bump versions
README.md | 4 ++--
configure.ac | 2 +-
2 files changed, 3 insertions(+), 3 deletions(-)

Upstream: cgit.freedesktop.org


  • Share