Fix subtle CONFIG_MODVERSIONS problems

Linux Kernel / Linux Kernel - Linus Torvalds [linux-foundation.org] - 25 November 2016 17:44 EST

CONFIG_MODVERSIONS has been broken for pretty much the whole 4.9 series, and quite frankly, nobody has cared very deeply. We absolutely know how to fix it, and it's not _complicated_, but it's not exactly pretty either.

This oneliner fixes it without the ugliness, and allows for further future cleanups.

"We've secretly replaced their regular MODVERSIONS with nothing at all, let's see if they notice"

###

diff --git a/init/Kconfig b/init/Kconfig
index 34407f1..c4fbc1e 100644
--- a/init/Kconfig
+++ b/init/Kconfig
@@ -1945,6 +1945,7 @@ config MODULE_FORCE_UNLOAD

config MODVERSIONS
bool "Module versioning support"
+ depends on BROKEN
help
Usually, you have to use modules compiled with your kernel.
Saying Y here makes it sometimes possible to use modules

cd3caef Fix subtle CONFIG_MODVERSIONS problems
init/Kconfig | 1 +
1 file changed, 1 insertion(+)

Upstream: git.kernel.org


  • Share