amd: remove support for LLVM 4.0

Graphics / Mesa 3D Graphics Library / Mesa - Marek Olšák [amd.com] - 17 May 2018 18:54 EDT

It doesn't support GFX9.

f9eb1ef870 amd: remove support for LLVM 4.0
.travis.yml | 6 +-
configure.ac | 4 +-
meson.build | 4 +-
src/amd/common/ac_llvm_build.c | 282 ++++++++-------------
src/amd/common/ac_llvm_helper.cpp | 12 -
src/amd/vulkan/radv_debug.c | 8 +-
src/amd/vulkan/radv_device.c | 9 +-
src/amd/vulkan/radv_nir_to_llvm.c | 2 +-
src/amd/vulkan/winsys/amdgpu/radv_amdgpu_winsys.c | 7 -
src/gallium/drivers/radeonsi/si_get.c | 4 +-
src/gallium/drivers/radeonsi/si_pipe.c | 2 +-
.../drivers/radeonsi/si_shader_tgsi_setup.c | 3 +-
src/gallium/winsys/amdgpu/drm/amdgpu_winsys.c | 7 -
13 files changed, 121 insertions(+), 229 deletions(-)

Upstream: cgit.freedesktop.org


  • Share