glsl: don't lower builtins to mediump that don't allow it