mesa: add explicit enable for EXT_float_blend, and error condition

Graphics / Mesa 3D Graphics Library / Mesa - Ilia Mirkin [alum.mit.edu] - 18 February 2019 17:13 EST

If EXT_float_blend is not supported, error out on blending of FP32 attachments in an ES2 context.

070a5e5d924 mesa: add explicit enable for EXT_float_blend, and error condition
src/mesa/main/draw_validate.c | 19 +++++++++++++++++++
src/mesa/main/extensions_table.h | 2 +-
src/mesa/main/fbobject.c | 4 ++++
src/mesa/main/mtypes.h | 2 ++
4 files changed, 26 insertions(+), 1 deletion(-)

Upstream: cgit.freedesktop.org


  • Share