mesa: add GLSLVersionCompat constant

Graphics / Mesa 3D Graphics Library / Mesa - Timothy Arceri [itsqueeze.com] - 9 May 2018 04:24 EDT

This allows drivers to define what version of GLSL they support in compat. This will be needed in order to support compat 3.2 without breaking drivers that wont support it.

4560aad780 mesa: add GLSLVersionCompat constant
src/mesa/drivers/dri/i915/intel_extensions.c | 1 +
src/mesa/drivers/dri/i965/intel_extensions.c | 6 ++++++
src/mesa/main/mtypes.h | 1 +
src/mesa/main/version.c | 4 +---
src/mesa/state_tracker/st_extensions.c | 1 +
5 files changed, 10 insertions(+), 3 deletions(-)

Upstream: cgit.freedesktop.org


  • Share