swr: bump minimum supported LLVM version to 4.0

Graphics / Mesa 3D Graphics Library / Mesa - Andres Gomez [igalia.com] - 20 February 2018 15:03 EST

Since radv and radeonsi removed support for LLVM 3.9 the distcheck target got broken because SWR distribution needed 3.9.x.

After checking with George Kyriazis, SWR is OK with moving to LLVM 4.0 and above, which will solve this problem.

Fixes: 3bf1e036e8a ("amd: remove support for LLVM 3.9") Cc: George Kyriazis Cc: Tim Rowley Cc: Emil Velikov Cc: Dylan Baker Cc: Eric Engestrom

36ac485bd1 swr: bump minimum supported LLVM version to 4.0
.travis.yml | 15 ++++++---------
configure.ac | 6 +++---
meson.build | 4 ++--
src/gallium/drivers/swr/Makefile.am | 2 +-
src/gallium/drivers/swr/SConscript | 4 ++--
5 files changed, 14 insertions(+), 17 deletions(-)

Upstream: cgit.freedesktop.org


  • Share