swr: bump minimum supported LLVM version to 5.0

Graphics / Mesa 3D Graphics Library / Mesa - Juan A. Suarez Romero [igalia.com] - 21 June 2018 10:16 EDT

RADV now requires LLVM 5.0 or greater, and thus we can't build dist tarball because swr requires LLVM 4.0.

Let's bump required LLVM to 5.0 in swr too.

Fixes: f9eb1ef870 ("amd: remove support for LLVM 4.0") Cc: Tim Rowley Cc: Emil Velikov Cc: Dylan Baker Cc: Eric Engestrom

d24839be70 swr: bump minimum supported LLVM version to 5.0
.travis.yml | 12 ++++++------
configure.ac | 7 ++++---
meson.build | 4 +---
src/gallium/drivers/swr/Makefile.am | 6 +++---
src/gallium/drivers/swr/SConscript | 4 ++--
5 files changed, 16 insertions(+), 17 deletions(-)

Upstream: cgit.freedesktop.org


  • Share