bluetooth: drop BlueZ 4 support (1)

System Internals / NetworkManager - Thomas Haller [redhat.com] - 12 August 2019 14:05 EDT

BlueZ 5.0 was released in December 2012 and broke API with BlueZ 4. NetworkManager supports Bluez 5 for years already.

Of course, version 4 is long gone by now, so remove it.

907ea9708 bluetooth: drop BlueZ 4 support (1)
Makefile.am | 7 +-
src/devices/bluetooth/meson.build | 2 -
src/devices/bluetooth/nm-bluez-manager.c | 30 +-
src/devices/bluetooth/nm-bluez4-adapter.c | 456 ------------------------------
src/devices/bluetooth/nm-bluez4-adapter.h | 57 ----
src/devices/bluetooth/nm-bluez4-manager.c | 355 -----------------------
src/devices/bluetooth/nm-bluez4-manager.h | 40 ---
7 files changed, 3 insertions(+), 944 deletions(-)

Upstream: cgit.freedesktop.org


  • Share