travis-ci: update build platform to Ubuntu 16.04 (xenial)

System Internals / NetworkManager - Thomas Haller [redhat.com] - 2 December 2019 16:25 EST

We kept building NetworkManager in travis on an ancient Ubuntu 14.04 (trusty). However, we already cannot install latest meson, because that would require a newer python
version. The used meson 1.44.1 does not support "link_whole". At this point, it's getting just too cumbersom.

Update the dependencies.

9c00eb5cb travis-ci: update build platform to Ubuntu 16.04 (xenial)
.travis.yml | 75 +++++++++++++++++++++++++------------------------------------
1 file changed, 31 insertions(+), 44 deletions(-)

Upstream: cgit.freedesktop.org


  • Share