Add support for OpenSSL 1.1.0 and newer versions in MSVC scripts

Enterprise / PostgreSQL - Michael Paquier [paquier.xyz] - 26 June 2019 01:44 EDT

Up to now, the MSVC build scripts are able to support only one fixed
version of OpenSSL, and they lacked logic to detect the version of OpenSSL a given compilation of Postgres is linking to (currently 1.0.2, the latest LTS of upstream which will be EOL'd at the end of 2019).

This commit adds more logic to detect the version of OpenSSL used by a build and makes use of it to add support for compilation with OpenSSL 1.1.0 which requires a new set of compilation flags to work properly.

The supported OpenSSL installers have changed their library layer with
various library renames with the upgrade to 1.1.0, making the logic a bit more complicated. The scripts are now able to adapt to the new world order.

d993e0fb82 Add support for OpenSSL 1.1.0 and newer versions in MSVC scripts
src/tools/msvc/Solution.pm | 121 +++++++++++++++++++++++++++++++++++++++------
1 file changed, 106 insertions(+), 15 deletions(-)

Upstream: git.postgresql.org


  • Share