Doc: remove some long-obsolete information from installation.sgml

Enterprise / PostgreSQL - Tom Lane [sss.pgh.pa.us] - 30 August 2019 17:02 EDT

Section 16.2 pointed to platform-specific FAQ files that we removed way back in 8.4. Section 16.7 contained a bunch of information about AIX and HPUX bugs that were squashed decades ago, plus discussions of old compiler versions that are certainly moot now that we require C99 support. Since we're obviously not maintaining this stuff carefully, just remove it. The HPUX sub-section seems like it can go away entirely, since everything it said that was still applicable was redundant with material elsewhere in the chapter.

In passing, I couldn't resist the temptation to do a small amount of copy-editing on nearby text.

Back-patch to v12, since this stuff is surely obsolete in any branch that requires C99.

Discussion: https://postgr.es/m/15538.1567042743@sss.pgh.pa.us

76c2af9266 Doc: remove some long-obsolete information from installation.sgml.
doc/src/sgml/installation.sgml | 311 ++++-------------------------------------
1 file changed, 28 insertions(+), 283 deletions(-)

Upstream: git.postgresql.org


  • Share