Doc: specify that the minimum supported version of Perl is 5.8.3.

Enterprise / PostgreSQL - Tom Lane [sss.pgh.pa.us] - 31 July 2017 13:42 EDT

Previously the docs just said "5.8 or later". Experimentation shows that while you can build on Unix from a git checkout with 5.8.0, compiling recent PL/Perl requires at least 5.8.1, and you won't be able to run the TAP tests with less than 5.8.3 because that's when they added "prove". (I do not have any information on just what the MSVC build scripts require.)

Since all these versions are quite ancient, let's not split hairs in the docs, but just say that 5.8.3 is the minimum requirement.

Discussion: https://postgr.es/m/16894.1501392088@sss.pgh.pa.us

dea6ba9 Doc: specify that the minimum supported version of Perl is 5.8.3.
doc/src/sgml/install-windows.sgml | 3 ++-
doc/src/sgml/installation.sgml | 3 ++-
2 files changed, 4 insertions(+), 2 deletions(-)

Upstream: git.postgresql.org


  • Share