Reject use of ucol_strcollUTF8() before ICU 53

Enterprise / PostgreSQL - Peter Eisentraut [gmx.net] - 10 August 2017 22:14 EDT

Various bugs can cause crashes, so don't use that function before ICU 53. It will fall back to the code path used for other encodings.

Since we now tie the function availability to an ICU version, we don't need the configure test anymore. That also resolves the issue that the test result was previously hardcoded for Windows.

researched by Daniel Verite, Peter Geoghegan , Tom Lane

Discussion: https://www.postgresql.org/message-id/flat/f1438ec6-22aa-4029-9a3b-26f79d330e72%40manitou-mail.org

d6391b0 Reject use of ucol_strcollUTF8() before ICU 53
configure | 38 --------------------------------------
configure.in | 16 ----------------
src/include/pg_config.h.in | 3 ---
src/include/pg_config.h.win32 | 3 ---
src/include/utils/pg_locale.h | 13 +++++++++++++
5 files changed, 13 insertions(+), 60 deletions(-)

Upstream: git.postgresql.org


  • Share