Remove some code for old unsupported versions of MSVC

Enterprise / PostgreSQL - Peter Eisentraut [eisentraut.org] - 8 October 2019 08:50 EDT

As of d9dd406fe281d22d5238d3c26a7182543c711e74, we require MSVC 2013, which means _MSC_VER >= 1800. This means that conditionals about older versions of _MSC_VER can be removed or simplified.

Previous code was also in some cases handling MinGW, where _MSC_VER is not defined at all, incorrectly, such as in pg_ctl.c and win32_port.h, leading to some compiler warnings. This should now be handled better.

38d8dce61f Remove some code for old unsupported versions of MSVC
src/backend/utils/adt/pg_locale.c | 23 +-
src/backend/utils/adt/selfuncs.c | 13 -
src/bin/pg_ctl/pg_ctl.c | 31 --
src/include/pg_config.h.win32 | 33 +-
src/include/port/win32.h | 2 +-
src/include/port/win32_port.h | 12 -
src/include/utils/float.h | 4 +-
.../ecpg/test/expected/pgtypeslib-nan_test.c | 107 +++----
.../ecpg/test/expected/pgtypeslib-nan_test.stderr | 354 ++++++++++-----------
src/interfaces/ecpg/test/pgtypeslib/nan_test.pgc | 7 -
src/port/chklocale.c | 4 +-
src/tools/msvc/Solution.pm | 2 -
12 files changed, 235 insertions(+), 357 deletions(-)

Upstream: git.postgresql.org


  • Share