Remove support for OpenSSL 0.9.8 and 1.0.0

Enterprise / PostgreSQL - Michael Paquier [paquier.xyz] - 6 January 2020 03:51 EST

Support is out of scope from all the major vendors for these versions (for example RHEL5 uses a version based on 0.9.8, and RHEL6 uses 1.0.1), and it created some extra maintenance work. Upstream has stopped support of 0.9.8 in December 2015 and of 1.0.0 in February 2016.

Since b1abfec, note that the default SSL protocol version set with ssl_min_protocol_version is TLSv1.2, whose support was added in OpenSSL 1.0.1, so there is no point to enforce ssl_min_protocol_version to TLSv1 in the SSL tests.

Author: Michael Paquier

7b283d0e1d Remove support for OpenSSL 0.9.8 and 1.0.0
doc/src/sgml/installation.sgml | 2 +-
doc/src/sgml/libpq.sgml | 4 ----
src/backend/libpq/be-secure-openssl.c | 2 --
src/interfaces/libpq/fe-secure-openssl.c | 5 +----
src/test/ssl/t/SSLServer.pm | 4 ----
5 files changed, 2 insertions(+), 15 deletions(-)

Upstream: git.postgresql.org


  • Share