bluetooth: Remove BlueZ 4 support

System Internals / PulseAudio - Luiz Augusto von Dentz [intel.com] - 21 June 2018 00:54 EDT

BlueZ 4 is no longer supported by BlueZ community for a long long time, also by moving to BlueZ 5 it should make it even more clearer that BlueZ 4 is no longer an option.

3b1093c0 bluetooth: Remove BlueZ 4 support
configure.ac | 16 +-
po/POTFILES.in | 1 -
po/be.po | 28 -
po/de.po | 28 -
po/el.po | 28 -
po/fr.po | 28 -
po/hr.po | 28 -
po/hu.po | 28 -
po/it.po | 28 -
po/lt.po | 64 +-
po/nn.po | 28 -
po/oc.po | 28 -
po/pl.po | 72 +-
po/pt_BR.po | 28 -
po/ru.po | 28 -
po/sk.po | 28 -
po/sv.po | 28 -
po/tr.po | 28 -
po/uk.po | 64 +-
po/zh_CN.po | 28 -
po/zh_TW.po | 28 -
src/Makefile.am | 26 -
src/modules/bluetooth/bluez4-util.c | 1851 --------------
src/modules/bluetooth/bluez4-util.h | 160 --
src/modules/bluetooth/module-bluetooth-discover.c | 13 +-
src/modules/bluetooth/module-bluez4-device.c | 2664 ---------------------
src/modules/bluetooth/module-bluez4-discover.c | 187 --
27 files changed, 61 insertions(+), 5505 deletions(-)

Upstream: cgit.freedesktop.org


  • Share