Xephyr: Require xcb-shm version 1.9.3 or newer

Graphics / X.Org / X.Org Server - Alexander Volkov [rusbitech.ru] - 14 February 2018 18:19 EST

It's needed for FD-passing.

###

diff --git a/configure.ac b/configure.ac
index 98b8ea2ed..9e498e662 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2305,7 +2305,7 @@ XEPHYR_INCS=
AM_CONDITIONAL(KDRIVE, [test x$KDRIVE = xyes])

if test "$KDRIVE" = yes; then
- XEPHYR_REQUIRED_LIBS="xau xdmcp xcb xcb-shape xcb-render xcb-renderutil xcb-aux xcb-image xcb-icccm xcb-shm >= 1.9 xcb-keysyms xcb-randr xcb-xkb"
+ XEPHYR_REQUIRED_LIBS="xau xdmcp xcb xcb-shape xcb-render xcb-renderutil xcb-aux xcb-image xcb-icccm xcb-shm >= 1.9.3 xcb-keysyms xcb-randr xcb-xkb"
if test "x$XV" = xyes; then
XEPHYR_REQUIRED_LIBS="$XEPHYR_REQUIRED_LIBS xcb-xv"
fi

8510f542e Xephyr: Require xcb-shm version 1.9.3 or newer
configure.ac | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

Upstream: cgit.freedesktop.org


  • Share