Obsolete nfsservctl

System Internals / glibc - Joseph Myers [codesourcery.com] - 18 May 2018 16:50 EDT

The Linux nfsservctl syscall was removed in Linux 3.1. Since the minimum kernel version for use with glibc is 3.2, the glibc wrapper for this syscall can no longer usefully be called. This patch makes it into a compat symbol, not provided at all for static linking or new ports. (It was already the case that there was no header declaration of this function.)

Tested for x86_64.

- sysdeps/unix/sysv/linux/syscalls.list (nfsservctl): Make into a compat symbol, disabled for minimum symbol version GLIBC_2.28 and later.

ebc129fd17 Obsolete nfsservctl.
ChangeLog | 4 ++++
NEWS | 5 +++++
sysdeps/unix/sysv/linux/syscalls.list | 2 +-
3 files changed, 10 insertions(+), 1 deletion(-)

Upstream: sourceware.org


  • Share