Require binutils 2.25 or later to build glibc

System Internals / glibc - Joseph Myers [codesourcery.com] - 28 June 2017 07:31 EDT

This patch implements a requirement of binutils >= 2.25 (up from 2.22) to build glibc. Tests for 2.24 or later on x86_64 and s390 are removed. It was already the case, as indicated by buildbot results, that 2.24 was too old for building tests for 32-bit x86 (produced internal linker errors linking elf/tst-gnu2-tls1mod.so). I don't know if any configure tests for binutils features are obsolete given the increased version requirement.

Tested for x86_64.

- configure.ac (AS): Require binutils 2.25 or later. (LD): Likewise.
- configure: Regenerated.
- sysdeps/s390/configure.ac (AS): Remove version check.
- sysdeps/s390/configure: Regenerated.
- sysdeps/x86_64/configure.ac (AS): Remove version check.
- sysdeps/x86_64/configure: Regenerated.
- manual/install.texi (Tools for Compilation): Document requirement for binutils 2.25 or later.
- INSTALL: Regenerated.

073e8fa Require binutils 2.25 or later to build glibc.
ChangeLog | 13 +++++++++
INSTALL | 2 +-
NEWS | 3 +++
configure | 2 +-
configure.ac | 2 +-
manual/install.texi | 2 +-
sysdeps/s390/configure | 65 ---------------------------------------------
sysdeps/s390/configure.ac | 6 -----
sysdeps/x86_64/configure | 64 --------------------------------------------
sysdeps/x86_64/configure.ac | 6 -----
10 files changed, 20 insertions(+), 145 deletions(-)

Upstream: sourceware.org


  • Share