Require GCC 4.9 or later for building glibc

System Internals / glibc - Joseph Myers [codesourcery.com] - 19 June 2017 12:34 EDT

This patch makes configure require GCC 4.9 or later for building glibc, and documents that requirement. Requiring GCC 4.9 or later allows use of _Generic (as in tzcode). It would allow and _Atomic to be used as well if desired, although we need to avoid any libatomic dependencies on any platforms. This patch is explicitly the minimum to implement a new version requirement, with any consequent cleanups of conditional code (not in installed headers or files shared with gnulib etc.) to be done separately.

Tested for x86_64.

- configure.ac (libc_cv_compiler_ok): Require GCC 4.9 or later.
- configure: Regenerated.
- manual/install.texi (Tools for Compilation): Document requirement for GCC 4.9 or later.
- INSTALL: Regenerated.

4add867 Require GCC 4.9 or later for building glibc.
ChangeLog | 8 ++++++++
INSTALL | 4 ++--
NEWS | 4 ++++
configure | 2 +-
configure.ac | 2 +-
manual/install.texi | 4 ++--
6 files changed, 18 insertions(+), 6 deletions(-)

Upstream: sourceware.org


  • Share