Require GCC 6.2 or later to build glibc

System Internals / glibc - Joseph Myers [codesourcery.com] - 1 February 2019 16:27 EST

As discussed during development for glibc 2.29, when we increased the required minimum GCC version for building glibc to GCC 5, working purely based on the times at which such requirements have been increased in the past it would be appropriate for glibc 2.30 to require GCC 6 (matching GCC 4.9 having been required for glibc 2.26). Naming 6.2 specifically as the minimum version then means a separate
version requirement no longer needs to be specified for powerpc64le.

Thus, this patch increases the minimum to 6.2, removing the documentation of the separate requirement for powerpc64le. It does not remove the powerpc64le configure test, or any __GNUC_PREREQ that could be removed as not being in installed headers or files shared with gnulib; I think such cleanups are best done separately.

Tested for x86_64.

- configure.ac (libc_cv_compiler_ok): Require GCC 6.2 or later.
- configure: Regenerated.
- manual/install.texi (Tools for Compilation): Update minimum GCC
version.
- INSTALL: Regenerated.

4dcbbc3b28 Require GCC 6.2 or later to build glibc.
ChangeLog | 8 ++++++++
INSTALL | 9 ++-------
NEWS | 5 ++++-
configure | 2 +-
configure.ac | 2 +-
manual/install.texi | 8 ++------
6 files changed, 18 insertions(+), 16 deletions(-)

Upstream: sourceware.org


  • Share