mkosi: update libqrencode in Debian config

System Internals / systemd - Alexey Bogdanenko [bogdanenko.com] - 15 December 2018 09:55 EST

In Debian unstable package libqrencode-dev is version 4.0.2-1, and the corresponding runtime library is provided by package libqrencode4.

This change fixes the following error when running journalctl:

root@image:~# journalctl journalctl: error while loading shared libraries: libqrencode.so.4: cannot open shared object file: No such file or directory

This change also fixes the following boot failures in systemd-journal-flush.service and systemd-journal-catalog-update.service:

[FAILED] Failed to start Flush Journal to Persistent Storage. [FAILED] Failed to start Rebuild Journal Catalog.

See also #4949

d3e5af044 mkosi: update libqrencode in Debian config
.mkosi/mkosi.debian | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

Upstream: github.com


  • Share