python3: upgrade to release 3.8.13

Desktop / LibreOffice - Taichi Haradaguchi [ymail.ne.jp] - 7 September 2022 14:02 UTC

Remove some code in external/python3/darwin.patch.0 as it was fixed upstream(https://bugs.python.org/issue45405).

Change-Id: Ie6bfb2456f96a63adbf0dbcb9c902dc56f1151ee Reviewed-on: https://gerrit.libreoffice.org/c/core/+/139493

###

diff --git a/configure.ac b/configure.ac
index 61806988b94b..f9d52805053b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -9984,7 +9984,7 @@ if test \( "$cross_compiling" = yes -a -z "$PYTHON_FOR_BUILD" \) -o "$enable_pyt
SYSTEM_PYTHON=
PYTHON_VERSION_MAJOR=3
PYTHON_VERSION_MINOR=8
- PYTHON_VERSION=${PYTHON_VERSION_MAJOR}.${PYTHON_VERSION_MINOR}.12
+ PYTHON_VERSION=${PYTHON_VERSION_MAJOR}.${PYTHON_VERSION_MINOR}.13
if ! grep -q -i python.*${PYTHON_VERSION} ${SRC_ROOT}/download.lst; then
AC_MSG_ERROR([PYTHON_VERSION ${PYTHON_VERSION} but no matching file in download.lst])
fi
diff --git a/download.lst b/download.lst
index 371ff954e2ba..6a86898646d8 100644
--- a/download.lst
+++ b/download.lst
@@ -216,8 +216,8 @@ export POPPLER_DATA_SHA256SUM := 2cec05cd1bb03af98a8b06a1e22f6e6e1a65b1e2f3816cb
export POPPLER_DATA_TARBALL := poppler-data-0.4.11.tar.gz
export POSTGRESQL_SHA256SUM := 9b81067a55edbaabc418aacef457dd8477642827499560b00615a6ea6c13f6b3
export POSTGRESQL_TARBALL := postgresql-13.5.tar.bz2
-export PYTHON_SHA256SUM := b1d3a76420375343b5e8a22fceb1ac65b77193e9ed27146524f0a9db058728ea
-export PYTHON_TARBALL := Python-3.8.12.tar.xz
+export PYTHON_SHA256SUM := 6f309077012040aa39fe8f0c61db8c0fa1c45136763299d375c9e5756f09cf57
+export PYTHON_TARBALL := Python-3.8.13.tar.xz
export QXP_SHA256SUM := e137b6b110120a52c98edd02ebdc4095ee08d0d5295a94316a981750095a945c
export QXP_TARBALL := libqxp-0.0.2.tar.xz
export RAPTOR_SHA256SUM := ada7f0ba54787b33485d090d3d2680533520cd4426d2f7fb4782dd4a6a1480ed
diff --git a/external/python3/darwin.patch.0 b/external/python3/darwin.patch.0
index 30d20ed57578..139cdc9780bb 100644
--- a/external/python3/darwin.patch.0
+++ b/external/python3/darwin.patch.0
@@ -8,15 +8,3 @@
.text

/* ffi_call_unix64 (void *args, unsigned long bytes, unsigned flags,
---- configure
-+++ configure
-@@ -5167,7 +5167,9 @@
- fi
-
-
-+if test "$(uname -s)" = Darwin; then MULTIARCH=; else
- MULTIARCH=$($CC --print-multiarch 2>/dev/null)
-+fi
-
-
- { $as_echo "$as_me:${as_lineno-$LINENO}: checking for the platform triplet based on compiler characteristics" >&5

c8fd50f9ec02 python3: upgrade to release 3.8.13
configure.ac | 2 +-
download.lst | 4 ++--
external/python3/darwin.patch.0 | 12 ------------
3 files changed, 3 insertions(+), 15 deletions(-)

Upstream: cgit.freedesktop.org


  • Share