Bump minimum Perl version to 5.14

Enterprise / PostgreSQL - John Naylor [postgresql.org] - 14 September 2022 05:37 UTC

The oldest vendor-shipped Perl in the buildfarm is 5.14.2, which is the last version that Debian Wheezy shipped. That OS is EOL, but we keep it running because there is no other convenient way to test certain non-mainstream 32-bit platforms. There is no bugfix in the 5.14.2 release that is required, and yet it's also not the latest minor release --that would be 5.14.4. To clarify the situation, we have thus arranged the buildfarm to test 5.14.0. That allows configure scripts and documentation to state 5.14 without fine print.

The MSVC build didn't check the version, since our previous minimum 5.8.3 was considered too old to check for on Windows. We will need a check for Windows sometime during the v16 cycle, but that could be rendered moot by the impending Meson conversion, so it seems safe to just document the requirement for now.

Reviewed by Tom Lane Discussion: https://www.postgresql.org/message-id/20220902181553.ev4pgzhubhdkguuv@awork3.anarazel.de

4c1532763a Bump minimum Perl version to 5.14
config/perl.m4 | 4 ++--
configure | 6 +++---
doc/src/sgml/install-windows.sgml | 2 +-
doc/src/sgml/installation.sgml | 4 ++--
src/pl/plperl/plc_perlboot.pl | 1 -
src/test/perl/PostgreSQL/Test/Cluster.pm | 2 +-
src/test/perl/README | 10 +++-------
src/tools/msvc/gendef.pl | 1 -
src/tools/pgindent/pgindent | 1 -
9 files changed, 12 insertions(+), 19 deletions(-)

Upstream: git.postgresql.org


  • Share