Remove ldd libc4 support

System Internals / glibc - Adhemerval Zanella [linaro.org] - 4 August 2022 13:03 UTC

The older libc versions are obsolete for over twenty years now.

36676f5e5d Remove ldd libc4 support
Makeconfig | 4 +-
sysdeps/unix/sysv/linux/Makefile | 2 -
sysdeps/unix/sysv/linux/csky/configure | 1 -
sysdeps/unix/sysv/linux/csky/configure.ac | 1 -
sysdeps/unix/sysv/linux/i386/Makefile | 5 --
sysdeps/unix/sysv/linux/i386/configure | 1 -
sysdeps/unix/sysv/linux/i386/configure.ac | 1 -
sysdeps/unix/sysv/linux/ldd-rewrite.sed | 10 ---
sysdeps/unix/sysv/linux/lddlibc4.c | 104 -------------------------
sysdeps/unix/sysv/linux/m68k/Makefile | 5 --
sysdeps/unix/sysv/linux/m68k/configure | 1 -
sysdeps/unix/sysv/linux/m68k/configure.ac | 1 -
sysdeps/unix/sysv/linux/sparc/sparc32/Makefile | 2 -
13 files changed, 2 insertions(+), 136 deletions(-)

Upstream: sourceware.org


  • Share