Require GTK+ version >= 2.16

Graphics / Pixman - Alexander Troosh [yandex.ru] - 11 June 2013 11:09 EDT

I'm got bug in my system:

lcc: "scale.c", line 374: warning: function "gtk_scale_add_mark" declared implicitly [-Wimplicit-function-declaration] gtk_scale_add_mark (GTK_SCALE (widget), 0.0, GTK_POS_LEFT, NULL); ^

CCLD scale scale.o: In function `app_new': (.text+0x23e4): undefined reference to `gtk_scale_add_mark' scale.o: In function `app_new': (.text+0x250c): undefined reference to `gtk_scale_add_mark' scale.o: In function `app_new': (.text+0x2634): undefined reference to `gtk_scale_add_mark' make[2]: *** [scale] Error 1 make[2]: Target `all' not remade because of errors.

$ pkg-config --modversion gtk+-2.0 2.12.1

The demos/scale.c use call to gtk_scale_add_mark() function from 2.16+
version of GTK+. Need do support old GTK+ (rewrite scale.c) or simple demand of high version of GTK+, like this:

###

diff --git a/configure.ac b/configure.ac
index b36298a..5b9512c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -778,7 +778,7 @@ PKG_PROG_PKG_CONFIG

if test $enable_gtk = yes ; then
AC_CHECK_LIB([pixman-1], [pixman_version_string])
- PKG_CHECK_MODULES(GTK, [gtk+-2.0 pixman-1])
+ PKG_CHECK_MODULES(GTK, [gtk+-2.0 >= 2.16 pixman-1])
fi

if test $enable_gtk = auto ; then
@@ -786,7 +786,7 @@ if test $enable_gtk = auto ; then
fi

if test $enable_gtk = auto ; then
- PKG_CHECK_MODULES(GTK, [gtk+-2.0 pixman-1], [enable_gtk=yes], [enable_gtk=no])
+ PKG_CHECK_MODULES(GTK, [gtk+-2.0 >= 2.16 pixman-1], [enable_gtk=yes], [enable_gtk=no])
fi

AM_CONDITIONAL(HAVE_GTK, [test "x$enable_gtk" = xyes])

279bdcd Require GTK+ version >= 2.16
configure.ac | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Upstream: cgit.freedesktop.org


  • Share